Need HTML/CSS customization support? Upgrade to CyberChimps Plus.

YouTube video not embedding into Featured Content area for homepage

Home Forums Free Themes Support ForumYouTube video not embedding into Featured Content area for homepage ResponsiveYouTube video not embedding into Featured Content area for homepage YouTube video not embedding into Featured Content area for homepage

This topic contains 5 replies, has 5 voices, and was last updated by  Vallari (CyberChimps Team) 10 months, 3 weeks ago.

  • Author
  • #212204


    I’m trying to embed a YouTube clip onto the Featured Content area for the homepage in the Customizer. I pasted both the iframe and just the YouTube URL. Neither seems to work. If I paste in the iframe, I get nothing and if I paste in the URL, that’s exactly what appears as the content. The URL. How do I fix?

  • #212217


    To have a YouTube video on your page, please goto your WordPress Dashboard->Pages. Edit the page in which you wish to have embedded video. In the editor select the ‘Text’ tab, by default the ‘Visual’ tab is active, hence pasting an iframe code will not work there.


  • #214050


    Silly question but I am accessing the Home Page via Appearance -> Theme Options, I have been having the same issue of entering the link to my video (which is uploaded in Media) and the text only is appearing. However when I go to Dashboard -> Pages, the Home Page doesn’t show – only a Sample Page.

    How do I get the Home Page to show up under Pages?

  • #214110


    As you are accessing your Homepage from Appearance -> Theme options, your front-page content is pulled from there itself. So you will find ‘Text’ tab on ‘Content Area’ setting field or on the ‘Feature Content’ field. Depending upon where you wish to show your video.

    Hope this helps you !

  • #270652


    Dear CyberChimps Responsive Theme Experts,

    After updating (WordPress 4.8.1) site’s ( Responsive theme, YouTube videos on the Home Page Featured Content no longer display. As you suggested, I logged in to the site’s WordPress admin account, navigated to the Dashboard > Appearance > Theme Options > Home Page tab; in the Featured Content editor I selected the ‘Text’ tab and pasted in the embed code; then click the Save Options button. I’ve also tried HTML and iframe code there, but none displays the YouTube videos now. I can’t determine what, if anything, I am doing wrong! Do you have any ideas? Thanks,


    [email protected]

  • #271100


    Apologies for the delay.
    Actually, I could not replicate the issue at my end.
    Can you please try once again by entering the YouTube iframe under “Theme options” > “Home Page” > “Featured Content” > “Text” tab.


You must be logged in to reply to this topic.