Trouble with Bootstrap?

CyberChimps Forums Premium Themes Support Forum iFeature Trouble with Bootstrap?

This topic contains 3 replies, has 2 voices, and was last updated by  Milind (CyberChimps Team) 1 week, 1 day ago.

  • Author
    Posts
  • #260959

    johnegan
    Participant

    Using iFeature Pro 5 on a website I’m designing. The problem is that one of the plug-ins also uses Bootstrap (loads twice). When I initially viewed the page, the menu was messed up. I contacted the plugin developer, who suggested that I add the following to my functions.php

    add_action(‘wp_enqueue_scripts’, function(){
    wp_dequeue_style(‘bootstrap_css’);
    wp_dequeue_script(‘bootstrap_js’);
    });

    When I did that, the plugin gets messed up.

    https://0337709.netsolhost.com/area61aa/meetings/

    To see what the plugin is supposed to look like,

    http://cflintergroup.org/meetings/

    Any help would be appreciated.

  • #260986

    Hi,

    Apologies for the delay in reply.
    Can you please let me know the version of the theme you are using? This will help me check the conflict with the version and help you with that.
    Also I think you are using 12 steps meeting list “https://wordpress.org/plugins/12-step-meeting-list/”. Just to confirm, so that I can install it and check the issue.

  • #260999

    johnegan
    Participant

    The version of the theme is 5.8. I set up a child theme to dequeue the bootstrap in functions.php. And, yes, the plugin is 12 step meeting list.

    Thanks for your help.

  • #261086

    Hi,

    Apologies for the delay in reply.
    I installed the plugin and ifeature pro theme but not able to replicate the issue properly.

    Please try adding below code in function.php file of the child theme. Save the page and check the issue.

    
    <?php
    function​ ​remove_styles() {
        //Remove desired parent styles
        wp_dequeue_style( 'bootstrap-style');
    	wp_dequeue_style( 'bootstrap-responsive-style');
    	wp_dequeue_script( 'bootstrap-js');
    }
    
    add_action( 'wp_enqueue_scripts','remove_styles', 10 );
    ?>
    

    Hope this helps.

You must be logged in to reply to this topic.