SEO meta title – Yoast & Business Pro 4.1

Home Forums Premium Themes Support ForumSEO meta title - Yoast & Business Pro 4.1 BusinessSEO meta title - Yoast & Business Pro 4.1 SEO meta title – Yoast & Business Pro 4.1

This topic contains 2 replies, has 1 voice, and was last updated by  tza 2 months, 2 weeks ago.

  • Author
    Posts
  • #286627

    tza
    Participant

    We’ve got an issue on https://www.zemaitis-uk.com where meta titles are not working as expected. Using Business pro / WordPress 4.9.4 / Yoast 7.

    Post & Page Title Templates are set to %%title%% %%sep%% %%sitename%% i.e. “SEO Title | Site Name”

    However, with Force rewrite titles disabled (default) the output when bookmarking a page/post is:
    “Site Title | Page Title | TaglineSEO Title (Found under Yoast SEO for the specific page)”
    NB no space between tagline & SEO Title created.

    But with Force rewrite titles enabled it simply outputs: “SEO Title”

    But Yoast don’t recommend using Force Rewrite as it can slow the site.

    Have tested with Troubleshooter – same issue still. No Java errors showing. Re-saving pages/posts makes no difference. Disabling plugins make to difference either.

    Yoast suggest in an article that title-tag support is required in the functions.php file but I cannot see it in Business pro – not sure if I’ve missed it?. See: https://kb.yoast.com/kb/the-seo-title-output-for-the-plugin-doesnt-work-as-expected/

    I see that in other posts you recommend Yoast to fix meta titles. Is there compatibility is the new versions of Yoast or WordPress?

    Any suggestions to remedy this will be appreciated.

    Thanks

  • #286642

    tza
    Participant

    Please ignore this – found it was ‘user error’ :)

  • #286643

    tza
    Participant

    Doh! Some of it is user error.

    I misunderstood what the meta title editor did until – with Force Rewrite, we are getting the correct meta title.

    However, with Force rewrite titles disabled (default) the output when bookmarking a page/post is:
    “Site Title | Page Title | TaglineSEO Title (Found under Yoast SEO for the specific page)”
    NB no space between tagline & SEO Title created.

    Yoast suggest in an article that title-tag support is required in the functions.php file but I cannot see it in Business pro – not sure if I’ve missed it?. See: https://kb.yoast.com/kb/the-seo-title-output-for-the-plugin-doesnt-work-as-expected/

    I see that in other posts you recommend Yoast to fix meta titles. Is there compatibility is the new versions of Yoast or WordPress?

    Any suggestions to remedy this will be appreciated.

    Thanks

You must be logged in to reply to this topic.