Missing bootstrap glyphicons

Home Forums Premium Themes Support ForumMissing bootstrap glyphicons Responsive II (Responsive Mobile)Missing bootstrap glyphicons Missing bootstrap glyphicons

Tagged: 

This topic contains 9 replies, has 4 voices, and was last updated by  Pallavi Chanodia 1 month, 2 weeks ago.

  • Author
    Posts
  • #271799

    henk2
    Participant

    In the customizer the developer tool (chrome) shows various 404 errors.
    They concern missing files in the bootstrap folder:

    glyphicons-halflings-regular.woff2 Failed to load resource: the server responded with a status of 404 (Not Found)
    glyphicons-halflings-regular.woff Failed to load resource: the server responded with a status of 404 (Not Found)
    glyphicons-halflings-regular.ttf Failed to load resource: the server responded with a status of 404 (Not Found)

    Please repair in next update.

  • #271938

    Hi,

    Can you please share your site URL and let me know the version of the theme you are using?
    I tried to replicate the issue on our test server but unable to do so. Can you please let me know the steps to replicate the issue?

    Can you please share the screen shot of the issue?

    Moreover, is the message getting displayed when you are trying to change any settings – which setting?

    Please share the details so that I can check the issue and assist you better.
    Thank you.

  • #271942

    henk2
    Participant

    I’m just working with the theme customzer (wordpress customizer, not options) when it shows up.
    Even when nothing is changed, these 3 errors appear in the inspect tool console window of chrome.

    The icons are expected to be in (that is the path that the browser reports):
    …/wp-content/themes/responsive-mobile/libraries/bootstrap/fonts/glyphicons-halflings-regular.woff2
    …/wp-content/themes/responsive-mobile/libraries/bootstrap/fonts/glyphicons-halflings-regular.woff
    …/wp-content/themes/responsive-mobile/libraries/bootstrap/fonts/glyphicons-halflings-regular.ttf
    In the theme however this ‘fonts’ folder is not there.

    Some glyphs are in …\wp-content\themes\responsive-mobile\core\bootstrap\fonts\bootstrap (glyphicons-halflings-regular.ttf and glyphicons-halflings-regular.woff).
    glyphicons-halflings-regular.woff2 is missing.

    The same bootstrap files seem to be in the PRO Plugin folder, cyberchimpsoptions. There are the same glyphs present in the folder:
    …\wp-content\plugins\cyberchimpsoptions\lib\fonts. There are 4 files.
    Also here is glyphicons-halflings-regular.woff2 missing.

    In Bootstrap 3.3.7 (the original) there are 5 files in the folder bootstrap-3.3.7\fonts

    So I think some components have landed in the wrong folder and 1 is missing. If there is a need to duplicate the theme code in the PRO plugin folder, it should be the same I think.

  • #271987

    henk2
    Participant

    I’ve added the fonts folder to responsive mobile 1.5 with the following default bootstrap 3.3.7 content
    wp-content\themes\responsive-mobile\libraries\bootstrap\fonts\glyphicons-halflings-regular.eot
    wp-content\themes\responsive-mobile\libraries\bootstrap\fonts\glyphicons-halflings-regular.svg
    wp-content\themes\responsive-mobile\libraries\bootstrap\fonts\glyphicons-halflings-regular.ttf
    wp-content\themes\responsive-mobile\libraries\bootstrap\fonts\glyphicons-halflings-regular.woff
    wp-content\themes\responsive-mobile\libraries\bootstrap\fonts\glyphicons-halflings-regular.woff2

    After this, the 404 error and others are gone.

  • #272187

    Hi,

    Thanks for sharing the details.
    I checked for the issue on our test server but unable to replicate it. The Google browser console is empty. There are no error messages.
    I will check again with different theme setting to replicate the issue.

    Moreover, Can you please share your site URL? Also, please confirm that you are using the theme version 1.5, which is the latest.
    Thank you.

  • #272233

    henk2
    Participant

    Milind,

    We use latest themes and plugins.

    You can replicate through installing responsive-mobile and the PRO plugin. Go to ‘customizer’ and reight click in chrom to inspect. At the bottom you see the errors as in my earlier message.
    Giving you the URL is useless. You need admin rights to see the WordPress customizer.

    I solved the issue by just creating missing folders and files from the original bootstrap in the theme.

  • #299750

    mikhail.krivoshein
    Participant

    grandstand theme appears to have the same issue. grandstand.zip\grandstand\cyberchimps\lib\bootstrap has css and img and js but no fonts

  • #300792

    Pallavi Chanodia
    Keymaster

    @mikhail.krivoshein,

    Can you please let me know on which page you are facing this issue? Will be nice if you can share the url. I just checked the demo site and can not see any such issues.

    Thank you.

  • #300940

    mikhail.krivoshein
    Participant

    At the home page. Deploy it to a new WordPress instance and then verify with Firefox or some other tool that can check for missing resources.

  • #301357

    Pallavi Chanodia
    Keymaster

    Hi,

    I checked on test site with latest grandstand V1.7. But can not see any issues or haven’t got any warnings. Will be great if you can share url so that I can check.

    Thank you.

You must be logged in to reply to this topic.