Need HTML/CSS customization support? Upgrade to CyberChimps Plus.

Lost my homepage

CyberChimps Forums Free Themes Support Forum Responsive Lost my homepage

This topic contains 33 replies, has 7 voices, and was last updated by  Bryan Hadaway 3 years, 1 month ago.

  • Author
    Posts
  • #128580

    pstoddard
    Participant

    When I went to my website last night I got an error that the homepage could not be found. I’m able to access every other page on the site except that one. I’ve tried to update it through the Theme Options but that hasn’t worked. I just changed my site over to the Responsive theme so I’m still trying to learn all the locations of the inner workings but I don’t think that the Theme Options area is where I created what appeared on the homepage before because I’m not able to add hyperlinks to the text in the Theme Options area.

    my site it teamtexarkana.com

    Also, all this happened before I updated to 1.9.3.7 and now my blog page is assigned to be the homepage for some reason.

  • #128585

    Christine
    Participant

    In your theme options under Homepage, is the box “Overrides the WordPress front page option” checked?

  • #128590

    pstoddard
    Participant

    It is checked at the moment but I believe that I have tried it both ways.

  • #128652

    Also, check your settings under Settings > Reading.

  • #128656

    pstoddard
    Participant

    Thanks for the suggestions Bryan. I checked the Reading page and “A Static Page” is selected but “Home” is not an option as the front page and wasn’t when I set up the new theme.

    Should “Override the WordPress front page option” be selected or not? From what I can make of it it should be checked.

  • #128664

    I’m going to have to forward this to our resident Responsive expert Ulrich, hold tight.

  • #128675

    awakekat
    Participant

    I am using the Free Responsive theme. I have created a child theme off of it and have started making my customized changes – this might be causing the problem but I will continue…

    I am having similar problem. Reading Settings are set to static home page called home. When I click Appearance > Theme Options > Home Page and UNCHECK Overrides the WordPress front page option, my home page goes White – nothing there. Could I be getting this white screen of death because I have created a child theme out of this theme??

  • #128676

    awakekat
    Participant

    Just to clarify what I mean by “I have created a child theme off of it”. I created a folder called responsive-child in the themes folder and put the style.css in it to override the parent theme – general WP way. Would this be causing the white screen when unchecking override?

  • #128689

    Ulrich Pogson
    Keymaster

    @awakekat child themes should not cause an issue.

    @both Please share your sites.

  • #128722

    Thomas Oliver
    Participant

    @pstoddard,

    Do you remember which version you upgraded from? If you were at an older version like 1.8.9.3, you’ll need to read this:
    https://cyberchimps.com/guide/setting-the-home-page-1-9-0-1-9-1/

    Also, there was an issue that was patched in this version, so you might want to try the latest.
    http://wordpress.org/themes/download/responsive.1.9.3.8.zip

  • #128778

    pstoddard
    Participant

    Thomas – I just started using this theme about a week ago so the version that I was using would have been the last version so 1.9.3.6

  • #128784

    Aaricia
    Participant

    I had the same problem and I fixed it so:
    Settings -> Reading – check Homepage shows the last posts
    And then on theme settings check “Overrides the WordPress front page option”
    or try some combination of these actions – but it works!

  • #128791

    pstoddard
    Participant

    Aaricia – Awesome. That worked great. I’ve got Override checked in Theme Options and Latest Post page selected in Settings

  • #128798

    Christine
    Participant

    Thanks for the info Aaricia

  • #128823

    Aaricia
    Participant

    I’m glad it works in your sites also :)

  • #128835

    Thomas Oliver
    Participant

    Thanks for the follow up.

  • #128851

    pstoddard
    Participant

    I have one final question though. When I set up this theme on my site a week ago I was able to set up the homepage so that the feature image and the 3 widgets were gone as well as “Hello, World!” and “Your H2 subheadline here”. My website logo took up the whole top. I didn’t do any CSS coding to get rid of these items.

    teamtexarkana.com

  • #128875

    Thomas Oliver
    Participant

    It sounds like the home page went back to the default settings. Go here and uncheck this:

    Appearance > Theme Options > Home Page > Enable Custom Front Page > Overrides the WordPress front page option > Save Options

  • #128892

    pstoddard
    Participant

    Thanks Thomas but if I uncheck “Overrides the WordPress front page option” it takes me back to the initial problem that I had of making by blog section of the website the home page.

  • #128895

    Thomas Oliver
    Participant

    Sorry, the long a thread gets the more confusing it can be.

    If you’re wanting your Blog to be your Home Page, make sure you have this set.
    Settings > Reading > Front page displays > Your latest posts > Save Changes

  • #128897

    pstoddard
    Participant

    Thomas – I also never uploaded that 1.9.3.8 zip file that you referenced yesterday. Do you think that would help?

    I just put that whole zip file into Appearance> Themes> Install Themes> Upload. Correct?

  • #128899

    Thomas Oliver
    Participant

    It wouldn’t hurt to try.

  • #128901

    pstoddard
    Participant

    Having “your latest posts” in the Reading Settings and “Overrides the WordPress front page option” selected is what’s returned my home page almost to what it was before other than the few things that I mentioned most recently.

  • #128922

    Ulrich Pogson
    Keymaster

    The new update does not make any difference. Please read this guide for how to set up a blog alongside the custom home page.
    https://cyberchimps.com/guide/setting-the-home-page/

  • #128926

    pstoddard
    Participant

    Thanks for this link Ulrich. The problem that I’m having is that I don’t have the option to select “Home” as my front page on the Reading Setting page. Every other page is there for me to select from.

  • #128956

    Ulrich Pogson
    Keymaster

    You don’t need to set the home page just the blog page. You can leave a setting blank.

  • #129145

    pstoddard
    Participant

    Ulrich – If I follow the instructions in the link that you sent and uncheck “Overrides the WordPress front page option” and on the Reading Setting page I select “A static page”, leave Front Page as “-Select-” and Posts page as “T3 Blog” it reverts back to what my original problem which was having the blog page as the homepage.

  • #129150

    Forwarding back to Ulrich.

  • #129475

    Ulrich Pogson
    Keymaster

    Keep the checkbox in the theme settings active, then go to the reading settings and set the the Posts page to the page you have created for the blog. The Front page option can be blank.

  • #129571

    pstoddard
    Participant

    As soon as I select “A static page” no matter whether I have “Override” selected or not it changes my home screen to my blog page and it will uncheck the “Override” option. I’ve been able to work around and make the front page work and have the home page show the way that I want it to but since I can’t select the blog page as my post page in Reading Setting all my posts are gone.

  • #129646

    You’ve of course actually made sure to create a “Blog” page under Pages first?

  • #129836

    pstoddard
    Participant

    Fixed it. On my blog page I had my template set to “Default Template”. I changed it to “Blog (full posts)” and now it works.

    Sorry for all the headaches I might of caused but I appreciate all your help.

  • #129838

    Good to hear.

  • #128904

    pstoddard
    Participant

    So I tried to install the 1.3.9.8 and this is what I get:

    Destination folder already exists. /home1/robklein/public_html/wp-content/themes/responsive/

    Theme install failed.

You must be logged in to reply to this topic.