Error when theme is activated

Home Forums Premium Themes Support ForumError when theme is activated iRibbonError when theme is activated Error when theme is activated

This topic contains 5 replies, has 3 voices, and was last updated by  Milind (CyberChimps Team) 1 week, 6 days ago.

  • Author
    Posts
  • #277580

    pablocaffiend
    Participant

    Whenever I have the theme activated I get errors like this in the dashboard when selecting any option.

    Warning: Cannot modify header information – headers already sent by (output started at /home/vykdbnpz/public_html/wp-content/themes/iribbonpro2/functions.php:920) in /home/vykdbnpz/public_html/wp-admin/includes/misc.php on line 1114

    Always references line 920 of functions.php – this is since I’ve updated the theme to the latest version.

    Any suggestions as to how to fix this?

    The problem goes away when I switch to a different theme. I’ve tried removing and reinstalling the theme.

  • #277623

    Hi,

    Understood your query. Can you please try below solution? You will have to edit one of the themes PHP files to fix this issue. But before doing any changes, please keep the backup of the file.
    1. Please login to your Cpanel account and move to /wp-content/themes/iribbonpro2/functions.php
    2. Open this function.php file and move to line number 909. You will find below code.

    
    /* To reduce the thumbnail size of the ribbon images */
    add_action( 'admin_menu', 'iribbonpro_modern_skin_css');
    function iribbonpro_modern_skin_css()
    {
    ?>
    <style>
    #customize-control-ribbon_style img
    {
        height: 50px;
    }
    </style>
    <?php
    }
    

    3. Remove above code, i.e from line number 909 to 921 including the empty line above and below the code (on line 908 and 922). Save the changes and check the result.

    Try it and let me know if you are still facing the issue.
    Thank you.

  • #277657

    pablocaffiend
    Participant

    Thank you! All works perfectly again after taking out that code.

  • #277731

    Hi,

    That’s great. Happy to hear that.
    Let me know if you have any more queries.

    Thank you.

  • #277977

    gene1
    Participant

    I had the same error and glad to see a workaround. Will this be fixed going forward so a new update to the theme doesn’t squash it?
    THx,

  • #278186

    Hi,

    Yes, I have noted this point and we will be fixing it in our next update.

    Thank you.

You must be logged in to reply to this topic.