Blog posts do not display

CyberChimps Forums Free Themes Support ForumBlog posts do not display ResponsiveBlog posts do not display Blog posts do not display

Tagged: ,

This topic contains 20 replies, has 6 voices, and was last updated by  Thomas Oliver 6 years, 1 month ago.

  • Author
    Posts
  • #81501

    gregscott
    Member

    I’m not sure how to dig into this.  The website is http://www.infrasupport.com.  It has a static front page and I am trying to set up a Posts page to show blog entries.  All the static pages work as I want.  The problem is the blog posts.  I am using Responsive 1.8.9.3.

    I made my first post, published it, then tried to view it.  All I see is sort of a blank page with my header logo and the main menu bar.  I can go back and edit my post as I see fit, but cannot display it.

    In wp-admin, I went to Settings…Reading and set my Front page to “Home” and my posts page to “Greg Scott blog page”.

    “Greg Scott blog page” is a blank page – it should show my blog posts because that’s what I told WP to do, right?  But when I show my Posts page, I see my logo and menu and what looks like the rest of the default Responsive Theme template.  But no blog content.   I’ll put this in the menu so you can see what happens.

    I guess I can always take my blog content and turn it into pages, but I’d like to have this section for an ongoing blog.

    How do I display blog entries?

    thanks

    – Greg Scott

  • #81503

    gregscott
    Member

    Hmmmm –

    I wonder what this error means:

    [Fri Mar 22 11:05:13.957387 2013] [:error] [pid 16975] [client 10.10.10.1:56744] WordPress database error Can’t create/write to file ‘/tmp/#sql_435_0.MYI’ (Errcode: 2) for query SELECT t.*, tt.*, tr.object_id FROM wp_terms AS t INNER JOIN wp_term_taxonomy AS tt ON tt.term_id = t.term_id INNER JOIN wp_term_relationships AS tr ON tr.term_taxonomy_id = tt.term_taxonomy_id WHERE tt.taxonomy IN (‘category’, ‘post_tag’, ‘post_format’) AND tr.object_id IN (267) ORDER BY t.name ASC made by require(‘wp-blog-header.php’), wp, WP->main, WP->query_posts, WP_Query->query, WP_Query->get_posts, _prime_post_caches, update_post_caches, update_object_term_cache, wp_get_object_terms, referer: http://www.infrasupport.com/

    An error like this seems to happen every time I select any page in that website.  I wonder if it’s related to the blog post problem?

    Also, I changed the name, “Greg Scott blog page” to just “Blog” to see if the spaces in the name made any difference.  No change in behavior.

    – Greg

  • #81504

    gregscott
    Member

    Oh wow, here’s another error:

    [Fri Mar 22 11:08:49.734730 2013] [:error] [pid 16105] [client 178.83.152.109:61949] PHP Catchable fatal error:  Object of class WP_Error could not be converted to string in /usr/share/wordpress/wp-content/themes/responsive/includes/functions.php on line 448, referer: http://www.infrasupport.com/2013/03/

     

  • #81505

    gregscott
    Member

    That first error about a problem opening something in /tmp does not look like a permission issue.  That directory is wide open.

    [[email protected] /]# cd /
    [[email protected] /]# getfacl tmp
    # file: tmp
    # owner: root
    # group: root
    # flags: –t
    user::rwx
    group::rwx
    other::rwx

    It’s also not an SELINUX issue  – SELINUX=permissive in my config file.

    And those errors may not even be related to my blog post issue.

  • #81521

    gregscott
    Member

    I am soo confused.  This link, http://themeid.com/docs/setting-the-home-page/, looks like it might be relevant to my issue.  If I am reading this correctly,  Responsive 1.8.9.3 and earlier needs some custom coding tweaks to make blog posts work.  This may be my problem, because I’ve been trying to do it the WordPress standard way.

    I have no child themes or custom css codes or anything like that.  I want to be as much out of the box as possible.

    The 1.9.0 upgrade apparently allows blog posts using the WordPress standard way, but has at least one bug that breaks the menu choices.  @ulrich posted a css workaround for this bug that I don’t understand yet, but I think @ulrich also posted a link to the documentation that explains it all.  But when the day comes and 1.9.1 hits the streets, what happens to that custom css workaround to make 1.9.0 menus work?

    So I could use some advice – what is the best and most supportable way to get this website where I can post blog entries?

    thanks

    – Greg Scott

  • #81596

    Dylan
    Participant

    I would suggest starting with a fresh install of wordpress.. it seems like your problems lie with the PHP files which we are unable to provide support on. Also, be sure you have all 3rd party plug ins disabled.

  • #81630

    gregscott
    Member

    @dylan – It pretty much is a fresh WordPress install.  I set it up my self a month or so ago.  The real issue is, how do I make blog entries work?

    I don’t know if the errors I posted are related to the fundamental problem or not.  This is my very first WordPress site and for all I know, they all behave this way.  You really want me to set up a new WordPress installation, figure out how to copy the database and all the content I’ve worked on for the past month, and then redeploy it in the new installation?  What do we do when the second installation behaves the same way as the original?

    Plus, the second error I posted that mentioned, “/usr/share/wordpress/wp-content/themes/responsive/includes/functions.php”  is your stuff, right?   I know it’s a php file, but it’s **your** php file.  If you don’t support it, how would anyone else?

    – Greg

  • #81663

    Ulrich Pogson
    Keymaster

    Hi Greg, Sorry that you are having this much trouble. The blog posts worked in all versions of Responsive. You can download this version which the bugs I know of are fixed.
    https://github.com/cyberchimps/responsive/archive/1.9.1.zip

    What I have found it can be the database that can cause errors and not just the WordPress files.

    As to your questions about the css here is some reading material.
    http://themeid.com/docs/adding-custom-css/
    http://themeid.com/docs/category/child-theme/

  • #81678

    gregscott
    Member

    Thanks Ulrich.  Yes, this is my first attempt at a WordPress website and it has definitely been an adventure.  I must be doing something important and worthwhile.  :)

    How do I find out what those database errors mean?  I’ve been searching around google with not much success.

    – Greg

  • #81686

    gregscott
    Member

    I stumbled across this link that might be helpful:
    http://stackoverflow.com/questions/11997012/mysql-cant-create-write-to-file-tmp-sql-3c6-0-myi-errcode-2-what-does

    I am hosting my website on a Fedora 18 system and evidently the new systemd does something ugly with /tmp when sqld starts up. Sqld is apparently trying to write its temporary database tables to some other deep down directory that it “thinks” is /tmp.

    The gist of that link above is, the new way that Fedora starts up messes with what msqld uses for its private tmp directory.   Sqld “thinks” it is using a system wide tmp directory, but in fact it’s using a private tmp directory. Apparently, Fedora removes these private tmp directories periodically – every 10 day or so?

    The net result is, everything works fine for 10 days, then the database errors kick in and strange behavior happens.

    To test this, I just restarted mysqld on my Fedora host and now I can click all over the place in my website with no errors.  And I can view my blog post.

    Clicking on my “Blog” menu is still broken, but I’ll have to come back to that later.

    – Greg

  • #81690

    Jamsandwich
    Member

    Hey Greg, nice site by the way.

    I’m pretty new to all this myself, but my website is set up similarly, with a home page and a seperate blog page.  My blog works though so maybe my settings will work for you.

    In the reading settings I have just selected the “Your Latest Posts” setting.

    My home page was still the standard responsive theme home without blog entries (though I’ve recently changed it).

    Once I set up my site I added a new page to be my blog page and changed the “Page Attributes” template to “Blog Excerpt (Summary)”.

    If this doesn’t work I guess your issue is a little beyond my reach :p

  • #81734

    Not sure I’ve ever seen this issue, so it’s highly likely that it’s something isolated on your specific setup as apposed to an actual bug in the theme.

    Just to be sure, double check you set this up correctly:

    https://cyberchimps.com/forum-topic/how-to-create-a-static-frontpage-and-separate-blog-page/

    Other things to rule out:

    – Flush the permalinks under Settings > Permalinks, just re-save however they’re already setup.
    – Make sure that your theme and WP install itself are completely up-to-date.
    – Try deactivating all plugins and clearing all caches.
    – Uninstall your theme and reinstall under Appearance > Themes.

  • #81747

    gregscott
    Member

    Thanks Bryan.   And also my apologies and thanks to you and Ulrich for your support.  Apologies because no matter where I go, the problems nobody has ever seen seem to find me.

    Re-saving the permalinks made no difference.

    Deactivating all the plugins made no difference with the menu problem.  However, my home page uses the Left Sidebar/Content template.  I use a Testimonial plugin for the left sidebar.  When I disable all plugins, a blog archive shows up in that left pane and I can select my blog entry from today.  To make sure I am not dealing with browser cache issues, I looked at the website from a different, freshly booted computer.  I’m going to turn my plugins back on now.

    I already have some before and after scenarios.  When I restarted mysqld on my Fedora 18 web host, the database errors stopped and I was able to view my blog post.   Based on the problem report at

    http://stackoverflow.com/questions/11997012/mysql-cant-create-write-to-file-tmp-sql-3c6-0-myi-errcode-2-what-does

    this is exactly the behavior I would expect to see.

    I still haven’t uncovered the menu problem and I’m hoping the upgrade to 1.9.1 will help with that.  I am a little gunshy about upgrading because of the problems I encountered with 1.9.0 last night – see the thread I started last last night,

    https://cyberchimps.com/forum-topic/1-9-0-upgrade-broke-my-menu/page/2/

    I’ve double and triple checked my settings as described in the link you provided above.  My static home page is named “Home”.  My post page is blank and named “Greg Scott blog”.  I’ve tried several templates on my Post page, they all behave the same.  I also deleted my original blank Post page and created a new one after the database fiasco.  No change in behavior.  So my menu problem may be a legacy from the database issue, or 1.9.1 may cure it.

    See these Bugzilla reports with Red Hat:

    First, I think this set up the database problem:  https://bugzilla.redhat.com/show_bug.cgi?id=782513

    And this is the one I just submitted:  https://bugzilla.redhat.com/show_bug.cgi?id=925983

    – Greg

  • #81749

    gregscott
    Member

    For @ulrich or @bryan – I am looking over the Responsive 1.9.1 that Ulrich mentioned.  When I unzipped it, I noticed the directory inside is “responsive-1.9.1” and not just “responsive”.  I’ve copied this whole directory tree to my web host at /usr/share/wordpress/wp-content/themes.  So now I have …themes/responsive-1.9.1 and …themes/responsive.

    Can I tell WordPress that Responsive-1.9.1 is a brand new theme, so then I would have two versions of the Responsive theme at the same time?   How would I do that?

    thanks

    – Greg

  • #81791

    gregscott
    Member

    A couple hours of sleep later…

    OK, So I look at Appearance….Themes.  I see a Responsive 1.9.0 as an available theme and my installed theme is Responsive 1.8.93.  I can look at a preview – the blog menu works in the preview!  But it says it’s 1.9.0 and not 1.9.1.  I wonder how it “knows”?  And is this available theme the one at WordPress or the one I just copied to the themese directory by hand?  Looking at the file named changelog – there’s only a mention of 1.9.0, not 1.9.1.  OK, maybe this 1.9.1 I downloaded per Ulrich still calls itself 1.9.0.  I activate it and…. no logo and menus look ugly.

    So then I activate the original responsive and manually delete the responsive-1.9.1 directory.  I’m a little spooked that it doesn’t match its name.  But, now looking at available themes, there’s no responsive 1.9.0.

    Then I copy it back over again – and sure enough, now I see another responsive as an available theme, but it still calls itself 1.9.0.  Hovering my mouse over tke Live Preview link, I notice the link goes to an ugly looking string with 1.9.1 in it.  OK, so I must be looking at the theme I copied by hand.

    Trying another Live Preview, my browser blows up with an error.  I can click the Back button a couple of times and see my stuff.

    And I see errors like this in error_log:

    [Sat Mar 23 05:02:07.974128 2013] [:error] [pid 21041] [client 10.10.10.1:63671] PHP Fatal error:  require(): Cannot redeclare class responsive_widget_menu_class in /usr/share/wordpress/wp-content/themes/responsive-1.9.1/functions.php on line 16, referer: http://www.infrasupport.com/wp-admin/themes.php

    I wonder what happens if I restart the httpd service?

     

  • #81794

    gregscott
    Member

    After restarting httpd on my host, now I can do a live preview of my newly copied Responsive-1.9.1.  The menus don’t show any heirarchy but at least seem to work.  I wonder what will happen if I upload my logo to this new theme again?

  • #81795

    Ulrich Pogson
    Keymaster

    If you have two different folders but with the same files that you should see two themes with the same name. I am sorry I cant help you much with the server as I do not know it that well. The settings are restricted to each folder in the theme folder.

  • #81798

    gregscott
    Member

    In Live Preview of 1.9.1 (that still calls itself 1.9.0), I set my “Greg First Menu” to be the header menu and left the other menus blank.  And viola, now the menu in the live preview looks like it should.  So I activate responsive 1.9.0 that’s really responsive-1.9.1.  And…it works.  “Greg’s blog” also shows a window with my first blog post.  But it’s missing my logo.

    No problem – I have a copy of that logo sitting in the media library.  Hmmm – actually two copies.   I upload the logo, tell it not to crop but keep the whole thing.  But I don’t expand the little handles all across the logo graphic, so it only shows the upper left part of the logo.  Probably 100×300 pixels.  But my logo is 200X960 pixels.  No biggie, I can just remove it and do it again.

    When I remove the logo – now I see 3 copies of my logo in the media library.  OK, so messing around with the logo creates another copy in the media library.  I can live with that.  I get rid of the extra two copies, set the new logo, this time remember to expand the handles, and ….

    It all seems to work!  All the menus behave as I expect, including the “Greg’s blog” menu.

  • #81839

    Ulrich Pogson
    Keymaster

    Ok great. I normally change the version number just before release. The update is already up for review.
    https://themes.trac.wordpress.org/ticket/11804

  • #81892

    gregscott
    Member

    Thanks Ulrich.  And now that I have a working blog, here is a blog entry describing what we’ve been through the past few days.  I think you will like it.

    http://www.infrasupport.com/and-now-this-blog-is-finally-visible-to-the-world/

    @jamsandwich – thanks for the good words.

    – Greg

  • #81950

    Thomas Oliver
    Participant

    Thanks for the follow up.

You must be logged in to reply to this topic.