For Developers Only: CyberChimps New Framework Now Publicly Available On GitHub

This theme framework is in an early beta, and is not for use on production websites.

If you are not familiar with Git, and WordPress development please disregard this blog post and wait for our official release coming later this month.

As promised, here is an early beta of our new framework.

In its current state this is for seasoned developers only, as we are still fixing several major bugs.

There is currently no documentation, and due to our use of Git submodules you will need to compile the theme yourself.

If you experience any bugs please submit a new issue to us on GitHub.

There are two ways to compile the theme:

1. The easiest way is to simply clone the “cyberchimpslite” repository directly into the /themes directory of a local WordPress install. Then download the submodules via Git, and activate the theme.

2. Download: https://github.com/cyberchimps/cyberchimpslite - as a zip file and unarchive it.

Then download: https://github.com/cyberchimps/core - rename the directory “cyberchimps” and replace the directory of the same name in the /cyberchimpslite/ directory you unarchived above.

Next download: https://github.com/cyberchimps/elementslite - rename the directory “elements” and replace the directory of the same name in the /cyberchimpslite/ directory you unarchived above.

Then zip the /cyberchimpslite directory and upload into a WordPress install, and activate it.

Thank you and happy bug hunting!